Rear Brake Won't Work - Yamaha FZ-09 Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 03-07-2015, 03:39 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Location: PA
Posts: 15
Rear Brake Won't Work

I installed my rear wheel for the first time today. I was being stupid and trying to install it with the brake caliper still on the mount. After 2 hours of back pain, I got the wheel on and the brake properly lined up with the rotor. I went to test my brakes, front brakes were amazing as usual. I pressed the rear brake, the lever goes all the way down and the brake mount twists as the piston pushes on the pads. There is barely any stopping power, but I do know that piston pushes since the mount is twisting. So how can I fix this issue? I don't think I need to bleed the brakes since the piston is pushing. I just think that the brake caliper isn't seated properly on the mount. Hence why the brake caliper twists as I push the pedal.

TLDR - Rear brakes won't do anything. Brake lever goes all the way down, but the piston is pushing since the brake caliper is twisting on the mount when the lever is pushed. How can I fix this issue?
desinoober is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-24-2015, 09:49 AM
Member
 
Join Date: Mar 2014
Location: Utah
Posts: 68
Garage
Have you pumped them over and over and there's still no resistance? You might need to pump them numerous time to get the fluid back in the caliper. It happens to me when I install wheels sometimes, just have to pump it over and over (10-15 times) until it feels stiff.

Since you rocked and tried to shimmy the rear wheel back into the caliper it might have forced a lot of fluid back into the rear reservoir. Check the rear brake reservoir, does it look full or half way full?

If that doesn't work then bleeding is in order.

'11 Ducati Streetfighter S
'13 Triumph Street Triple R
'12 Triumph Bonneville
'10 BMW F800GS
'13 Yamaha FZ-09
'76 Honda cafe
'76 Honda cafe
Piggyboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha FZ-09 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help rear brake light out Swallace226 FZ-09 General Discussion forum 6 05-21-2014 01:49 PM
Will this shock work? Brvt1000 Yamaha FZ-09 Parts & Accessories 8 04-28-2014 01:05 PM
Bike won't start 0 miles on it Swallace226 Yamaha FZ-09 Issues and Troubleshooting 36 04-16-2014 04:24 PM
Hit on the way to work 9/23/13 motomania FZ-09 General Discussion forum 30 10-05-2013 01:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome